Blogs Download 2.15

This component/theme works with latest OSSN version.
German ~Z~ Man 5 years ago

Blogs


A component allowing members to create simple blogs in your social network.

For your convenience, all Ossn default language files are already in place, but (except of the English and German one) still need translation.
Volunteers are welcome!
You can send your translated ossn.XX.php language files to
[email protected]


Note: This component needs TextareaSupport to be installed and enabled, first.


Changes:

V 2.15

  • fixed crash on edit- and add-page if member is not logged in

V 2.14

  • requirements adapted to Ossn 5.4

V 2.13

  • blogs with complete list of comments may be shared anywhere now
  • copy share link to clipboard for easier pasting
  • fixed overlapping of blog wall entries if blog starts with an image or a video
  • added Chinese language file
  • adapted to TextareaSupport 2.8

V 2.12

  • refined components requirement check
  • added Indonesian language file
  • license update

V 2.11

  • compatibility fixes for TextareaSupport 2.5

V 2.10

  • added blog content search

V 2.9

  • fixed shared link for sites with Ossn root in a subdirectory

V 2.7

  • Android compatibility fix for share widget (make link selectable)

V 2.6

  • added 'Share' button displaying a link to be used outside your Ossn community
  • ugly 'sort by' link replaced by bootstrap button

V 2.5

  • fixed issue with lowercase tab on profile page
  • placeholder added to title field to prevent it from being left blank

V 2.4

  • Blog lists will display a 'last edit' timestamp now and may be sorted by date (most recent on top) or by member names (alphabetically)
  • In case you're not satisfied with the format of the timestamp you can easily customize it by editing line #23 of the component's language files

V 2.3

  • fix disappearing blog previews from newsfeed page 2 and above

V 2.2

  • hide blog pages from logged out members

V 2.1

  • some sanitizing added to blog preview

V 2.0

  • WYSIWYG editing
  • a 300 character preview of the blog is shown on the main wall
  • blogs can be liked and commented
  • blog owner notifications on likes and comments
  • cancel/back links for easier navigation

V 1.0

  • initial release
Comments
Dutch Everwijn Overberg Replied 3 months ago

Thank you for the effort of updating the component. Unfortunately I can not tell you if the update worked because I solved it before I saw you did.

I did a little digging and it seems that Tiny MCE and Chrome have had a love/hate relationshop dating as far back as 2016 causing this type of problem. The fix is simple, but why it works I don't understand.

If you get the blank field instead of the editor all you have to do is go to Chrome settings --> Advanced --Reset settings that fixes it. Afterwards you can simply activate all plugins and extentions you use in Chrome the editor keeps working. Don't ask me why.

In any case the problem is solved this way and I moved on to another issue I have but that is not for this page, because it is about another component. ;-)

German ~Z~ Man Replied 3 months ago

Thank you very much for your helpful feedback, Everwijn.

Unfortunately, I don't own a Chromebook to verify why the editor is not? or too late? initialized, but I have changed the code a) to allow a little more initialization time, and b) if that still fails to pop up an alert box to let your members know that their device/browser is not compatible, and c) hide the input field afterwards in order to make editing impossible.

Please give it a try and

  1. temporarely disable all components (Blog,Bio, About User) that depend on TextareaSupport
  2. Delete TextareaSupport 2.9
  3. Upload and enable TextareaSupport 2.10
  4. Re-enable the candidates of step 1

I'm curious of the result.

Dutch Everwijn Overberg Replied 3 months ago

Found the problem there is nothing wrong with the script the problem is the version of Google chrome on chromebooks.

Tested Firefox, woks
Tested Chrome on my Huawei Mate 10 pro from the app store - Works
Tested Chrome on a Windows 10 PC - works
Tried my chromebook version of Chrome - Blank field.

Time to start nagging google :-)

Cheers!

Dutch Everwijn Overberg Replied 3 months ago

Well first off thanks for checking Z-Man it is very much appreciated.

What I did was turn off Password Validation. I am also happy to see that you got the editor. I am still seeing a blank field, but I at least I now know that is in my end and not the site, which helps a lot. I think I will go over all the components and as much as possible swap everything out for 5.4 versions if they are there.

On a side note, as you may have noticed I am translating everything into Dutch. I am far from finsihed but you are welcome to the language files

German ~Z~ Man Replied 3 months ago

maybe you located the problem in the meantime ... at least I had no issues at your site and was able to create a new blog with the text-editor
enter image description here

German ~Z~ Man Replied 3 months ago

Ok, that's a start. And as already expected: A Javascript error.

I talked to Arsalan this morning and he said to have no issues with plain new premium and latest Blogs and TextareaSupport. So it's likely your issue is caused by any other extra component you're running.
Unfortunately these script errors are not easy to track down because - as we see in your case - the real problem already appeares in the PasswordValidation component. Which doesn't mean that PasswordValidation is buggy. Just installed latest version here, giving no issues.

So all I can recommend is running through the circle:
- check your log
- disable the mentioned component
- visit the blog page
- check your log again
... and so on ... until there's no more script error
this is the only chance isolate the bug

Of course ... in case you did any Javascript modifications yourself ... remove them first.

Dutch Everwijn Overberg Replied 3 months ago

The console gives me this:

Uncaught TypeError: Cannot set property 'content_css' of undefined
at add:428
DevTools failed to load SourceMap: Could not parse content for https://urubin.nl/components/PasswordValidation/vendors/underscore-min.map: Unexpected token < in JSON at position 0

Dutch Everwijn Overberg Replied 3 months ago

Thanks but blogs are not part of the premium package. I got the Blogs component from here not softlab24. Not sure if they provide suport in such a case?

German ~Z~ Man Replied 3 months ago

From your description it looks like the Texteditor's initialization fails due to a Javascript error.

You can try to press F12 to open the browser's developer window, choose the 'console' tab to find red listed errors yourself, or maybe ask for support at Softlab24.

Dutch Everwijn Overberg Replied 3 months ago

Hello,

I upgraded from 5.2 to 5.4(Premium) and noticed the Blogs component no longer worked. I deleted and reinstalled Blogs and Text Area Support latest version and it works again but without the WYSIWYG editor it used to have. I now only see a blanc text area and when you try to edit a previous blog it shows the HTML code. Is it supposed to be like that, or have I forgotten something?

Component

Developer: ~Z~
License ossnv4
Type: Communication
Minimum Requirement: 5.4
Latest Version: 2.15
Last Updated 3 months ago
Repository Url View Repository

Versions