Minimum signup age Download 2.0

This component/theme works with latest OSSN version.
German Alex Daniel 4 years ago

Set the age limit to minimum 18 years old on signup form.

With the reason going disucssion : https://www.opensource-socialnetwork.org/discussion/view/1371/how-i-can-setup-minimum-registration-age

I as part of softlab24 ltd developers team created a component.

Comments
us Erik M Replied 3 years ago

Any way to change "Username is invalid." to a notice that explains they not old enough to sign up?

Even if it a piece of code I can add.

Thanks

German ~Z~ Man Replied 4 years ago

Cannot follow, Jordan. The component is working 100% correctly.
In fact you cannot enter a birthday below 18 and that's why you won't see any errors.

Of course, a younger user will still be able to fool the system by entering a wrong birthday - but this simple component wasn't meant to verify your passport or identity card.

gb Jordan Sheppard Replied 4 years ago

when signing up the component doesnt state 18+ or gives error if input DOB is below 18.

Breton Fabio pacheco Replied 4 years ago

how do I install this component, the installer as invalid.

us David Aguilar Replied 4 years ago

Good component idea.

Turkish Fatih Bayram Replied 4 years ago

Thanks.

German Arsalan Shah Replied 4 years ago

Thanks Alex for creating component.

Component

Developer: Alex
License ossnv3
Type: Tools
Minimum Requirement: 4.6
Latest Version: 2.0
Last Updated 5 months ago
Repository Url View Repository

Versions