Problem with the images uploading

Cv Gandhi Posted in Technical Support 9 months ago

Hi,

after the ossn setup everything is working good but the images are not uploading. There is this error i got after uploading my profile picture:

<pre>TypeError: imagejpeg(): Argument #2 ($file) must be a file name or a stream resource, bool given in /Applications/XAMPP/xamppfiles/htdocs/social/classes/OssnImage.php:343
Stack trace:

0 /Applications/XAMPP/xamppfiles/htdocs/social/classes/OssnImage.php(343): imagejpeg(Object(GdImage), false, 50)

1 /Applications/XAMPP/xamppfiles/htdocs/social/classes/OssnImage.php(385): OssnImage->save(false, 2, 50)

2 /Applications/XAMPP/xamppfiles/htdocs/social/libraries/ossn.lib.image.php(60): OssnImage->getImageAsString(2, 50)

3 /Applications/XAMPP/xamppfiles/htdocs/social/classes/OssnFile.php(397): ossnresizeimage('/Applications/X...', 1500, 1500, false)

4 /Applications/XAMPP/xamppfiles/htdocs/social/classes/OssnFile.php(355): OssnFile->imageResize()

5 /Applications/XAMPP/xamppfiles/htdocs/social/components/OssnProfile/actions/photo/upload.php(35): OssnFile->addFile()

6 /Applications/XAMPP/xamppfiles/htdocs/social/libraries/ossn.lib.actions.php(51): include_once('/Applications/X...')

7 /Applications/XAMPP/xamppfiles/htdocs/social/system/handlers/actions.php(13): ossn_action('profile/photo/u...')

8 {main}</pre>

All of the permission are good and every checked passed while installation.
Its XAMP with php 8.1 on mac os

Replies
vn Isabelle Briggs Replied 9 months ago

lol beans I'm happy to chat on your blog, and it seems like I should be looking forward to more dependable content. I believe that all of us would like to thank you for sharing so many fantastic articles and blogs with us.

Indonesian Arsalan Shah Replied 9 months ago

Please install on actual hosting provider as there can be many issues on MAMPS , XAMPPS , WAMPS ETC