New users who are using gmail are not receiving the first email

Peter Lane Posted in Technical Support 5 months ago

I have found that new users who have a gmail account are not receiving emails when they sign up. All other email addresses have worked so far.

My admin address can send to gmail from my own email client and it is received at my account there. But if I set up account with that address, OSSN does not seem to send one, or at least it is not received.

Any ideas?

gb Peter Lane Replied 5 months ago

I am grateful for all your attention! As I have said below, the use of the SMTP component has now allowed me to send email from the system to gmail accounts.

German Michael Zülsdorff Replied 5 months ago

Peter, wasn't your initial problem sending mails to GMAIL addresses?

This test confirms the successful sending of messages to MYGRWORLD.COM, though.

Not sure whether I should start wondering again or just stop... ;)

gb Peter Lane Replied 5 months ago

@Arsalan, I have no problem with SMTPer. As you see I connect to my domain which is hosted on A2Hosting

SMTP example

Indonesian Arsalan Shah Replied 5 months ago

@Peter which port you tried ? 587?

Because I can not able to connect with A2hosting with that port or 467. Also any SMTP test tool hangs too example So please tell us which port and configurations you used for A2 hosting connection.

gb Peter Lane Replied 5 months ago

@Grep, oh go to, they will give you a rundown of what they see as needing to be done for your mail server. So, use your as the domain name and choose to run MX Lookup.

gb Peter Lane Replied 5 months ago

@Greg, you will need to ensure that the DNS for your mail server is configured with correct DNS records for spf, DMARK and DKIM. Google is particular over their construction. There is plenty of help around if you search on Google, and your provider should also be able to help.

gb Peter Lane Replied 5 months ago

@Michael, I have just reinstalled, since I was getting 504 when I tried to even run the configuration! Now, i can configure it and have done so with that different port. I have been able to successfully send an invite. So, thank you, things seem to be working as expected

us Greg mattingly Replied 5 months ago

I'm using a vm with VMWare and having email issues to gmail. I assumed everything would be configured .. was that wrong? What needs to be done or undone? Thanks

German Michael Zülsdorff Replied 5 months ago

Try to use port 587 instead.

Aside from that: 2 days ago you wrote you had transferred your domain to IONOS, now it's A2?

gb Peter Lane Replied 5 months ago

I attach an image of what I am trying to configure with the SMTP component. The domain is hosted with A2Hosting using port 465. The response on submit is the 504 error.

SMTP request