Open Source Social Network 7.1 released

Arsalan Shah Posted in General Discussion 1 week ago

Open Source Social Network 7.1

  • [B] Command to replace slash to backslash missing in vendors/jwt/autoload.php #2274
  • [B] ossnisfrom_cli is returning true on non-cli #2262
  • [B] Unaccepted friend appears in getFriends #2265
  • [B] OssnPhotos::getPhoto should not return other file types #2272
  • [B] hide group members and subpages for private groups #2276
  • [B] Tinymce lists and bullets missing from topbar #2267
  • [E] OssnNotifications check new one on mark all as read #2266
  • [E] Default search result type confusing #2279
  • [E] improve username invalid message #2273
  • [B] Emojis shows entities in trimmed message notification #2257
  • [E] Remove /register page what is it doing? #2270
  • [E] Add max-height in .ossn-wall-item .post-contents img #2259
  • [E] Don't open the last message in messages/all #2283
  • [E] Allow attachment of image in message without text #2268
  • [E] Bootstrap badges have blue on however should be same color #2269
  • [E] output/user/url should have data-username #2284
  • [E] remove Ossn.Viewer js #2286
  • [E] Fontawesome 5.x to 6.x #2285
  • [B] Message typing UI bug for OSSN chat #2288
  • [E] Show only online members in Chat #2287
  • [B] OssnChat showing only 10 users #2263
  • [E] Add option to trigger manually messagebox/overlay box #2277
  • [E] Merge Hungarian langauge #2289
  • [E] phpmailer update #2292
  • [E] new zip mime type #2293
  • [E] Improve installation script #2294
  • [E] Add style to checkboxes #2291
Indonesian Arsalan Shah Replied 4 days ago

Glad to hear that it worked

German Holger A. Replied 4 days ago

The old .htacess file, not working with Apache 2.4, is still in the source directory of OSSN. If it is okay, I'll exchange or add a working .htacessfile for Apache 2.4 in the zip file. I copied this file into my root directory of OSSN - and it's working!

German Holger A. Replied 5 days ago

Hio Arsalan, I tried to upgrade to 7.1 from 7.0 (I followed the instruction). the upgrade with /upgrade/upgrade.php failed, OSSN broke down, It doesn't work any more, I get an error-500 message. I tried to install it completely new, (I deleted the OSSN files and the PHP database and have created new one). Nothing. It failed. I still get an error 500 message
There must be an error in the instruction file (I want to start unstallation, the file seems to be incomplete, and I got the message error 500 again.