Open source social network is not working

Horrid Henry Posted in Beginning Developers 2 weeks ago

I downloaded and installed the open source social network I went though the set up process made my admin account I did all of this in wamp and when I was done it returned me to the home page of the site with nothing but a blank white screen what am I doing wrong?

Replies
German ~Z~ Man Replied 7 days ago

@Holger A.

I have also the problem, that OSSN is not working correctly with PHP >
7.0.

I don't see where Horrid would have written anything like that. So please respect other member's threads and open your own one for own issues. Aside from that and as Arsalan already wrote please follow the steps documented in https://www.opensource-socialnetwork.org/wiki/view/1101/how-to-report-a-bug-error

German Holger A. Replied 1 week ago

I have also the problem, that OSSN is not working correctly with PHP > 7.0.

I have installed PHP 7.2 on my NAS, when I start OSSN after installing new components or themes or even when I'm logging into my OSSN, i get the error message:
SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

I had to close browser and after that, it mostly works. Not always

German ~Z~ Man Replied 1 week ago

Windows wamps are known for bad surprises - that's why they're not supported. Ossn's pre-requisites are documented in
https://www.opensource-socialnetwork.org/wiki/view/706/how-to-install-open-source-social-network

For testing purposes you may run Ossn in a virtual Linux machine hosted on your Windows, see
https://www.opensource-socialnetwork.org/download-vm-image

gb Horrid Henry Replied 1 week ago

I uploaded a YouTube video showing around my wamp and ossn maybe you can figure out why it's not working https://youtu.be/oeGz8JyNgBg I tried going to different directories in the URL bar nothing worked

German Arsalan Shah Replied 2 weeks ago

Hi please see : https://www.opensource-socialnetwork.org/wiki/view/1101/how-to-report-a-bug-error, there can be many reasons behind this, like your server permission issue, configuration issue issue. etc.

ge John johnny Replied 2 weeks ago

Have no idea how wamp works but i had the same problem. So this might be of no help but i'll share my experience.
It might occur because of the directory you installed ossn in. Let's say www.yoursite.com/ossn(default directory) is where you installed the ossn, then you will see blank page when browsing www.yoursite.com

All i did was changing the directory. When installing(i used softacular), you will see /ossn or just ossn without slash.
Delete that part and you are set(it will choose your website as a default directory). If that is what caused the problem then it should work.