Upgraded to OSSN 6.0 and nothing really works...Somethings do

Joel Sullivan Posted in Technical Support 9 months ago

Upgraded to OSSN 6.0 from 5.7 and my dropdowns don't work. When I hover over them I get a "javascript:void(0);"
I followed the guide and with no luck. I can get to different parts of the site if i enter the URL directly.

I've tried to reload php/apache/sql with no luck.
I've tried this a few times and I still get the some outcome.
Theme is GoBlue
Cache is still disabled. (When I do enable cache it stuffs up the layout of the site and is useable).
File version and OSSN version say 6.0

Let me know if you need anymore info.
Kudos :)

Replies
au Joel Sullivan Replied 9 months ago

@ralph try using a different browser or clear cache on you current one. Things will work. Same issue I had.
As Arsalan said: Its issue with boostrap 3.x js file cached. After clearing browser cache its working fine.

us Ralph Pearcy Replied 9 months ago

it don't give me an error just the drop down menus don't work on my site facesplash.org

us Ralph Pearcy Replied 9 months ago

I couldn't even turn the cache back on or anything it would not let me use the drop down menu for anything i could not get back in the admin panel or the part to turn cache back on

Indonesian Arsalan Shah Replied 9 months ago

@Balamurali for your social network version its different https://www.openteknik.com/wiki/view/28470/how-to-upgrade-my-premium-social-network-to-newest-version

You can't replace files as some files are removed on purpose if they exists after upgrade you will get errors.

au Joel Sullivan Replied 9 months ago

@Balamurali
Yeah just copy and overwrite those existing files. You may need to change some of the photos in your themes.
All I did was "unzip ossn-v6.0-1632413382.zip" then A for All.

You may need to update some components tho.

For the theme if it has been updated to support version 6 then yes.

in Balamurali Govindan Replied 9 months ago

To upgrade we just need to copy the files on top of the existing files? That's it or is there an Upgrade tool/utility? For DB changes do we need to run any script?

Please help.

Also will this work for the white theme?

au Joel Sullivan Replied 9 months ago

@Ralph, did you clear your cache on your browser? Try logging in with incognito mode.
What does your error log say?
cat /var/www/html/ossn/error.log

us Ralph Pearcy Replied 9 months ago

i went to upgrade to ossn 6.0 and it tells me that there is nothing to upgrade and then when i go to the4 site i can use the drop down menus or anything it messed up my whole site i had to redo it all

Indonesian Arsalan Shah Replied 9 months ago

Its issue with boostrap 3.x js file cached. After clearing browser cache its working fine.

au Joel Sullivan Replied 9 months ago

Don't worry guys. It has started to work. No idea how or why. But it does