Installation doesn't recognize my right php version

Francesco Boserman Posted in Technical Support 3 months ago

Hi, I'm trying to install OSSN in my hosting wich has a php version 7.2.7. but when I run the installer in the check list appera this message "You have an old version of PHP 5.5.38 You need PHP 5.6 or 7.x".
Clearly is an error (because my hosting ru php 7.2.7) but i dont know how to fix this problem and follow with the installation process.
Any suggestion? Please help!

Replies
German Arsalan Shah Replied 3 months ago

This looks like you have many php version but php 7.2 is not default. See : https://github.com/opensource-socialnetwork/opensource-socialnetwork/blob/v5.x/installation/locales/ossn.en.php#L43 the php version mentioned in message is directly from your server.

You may also see : https://github.com/opensource-socialnetwork/opensource-socialnetwork/blob/v5.x/installation/classes/OssnInstall.php#L101