Problem with the upgrade from ossn version 4.6 to 5.0

Greta Kane Posted in Technical Support 1 month ago

I upgraded ossn version from 4.6 to 5.0 on my local server and it works fine, but when I transferred the files to the remote server, it does not work, as the image below shows
Why ?? Please help. Thank you
enter image description here

Replies
gr Greta Kane Replied 1 month ago

Arsalan the problem was not the broken page, the page was fine, it was the ossn version as shown in the image above
it could not get upgraded
as for the VPS, i didnt ask for any special configuration
anyway i just transfered the site to the VPS and the problem is solved
thank you

German Arsalan Shah Replied 1 month ago

Regarding VPS it is not true at all, it looks like your VPS is configured correctly as per your need, the hosting configure the stuff by changing .htaccess etc and upon upgrade the .htaccess is rewritten to original this may be causing you issue on shared hosting.

As zetman suggested , restoring the original .htaccess file should solve your issue , additionally i believe you have followed the upgrade guidelines and without disabling the cache you guys delete the old files including cache folder and uploaded v5.0 files causing the broken page (no css)

gr Greta Kane Replied 1 month ago

For your information, if anybody deals with the same issue :
OSSN cannot be upgraded to version 5.0, if your files are on a HostGator shared host
You need to transfer your OSSN site to a VPS
Thats how I solved my upgrade problem and now OSSN v. 5.0 works fine
Thank you again ~Z~ Man for all the previous support

gr Greta Kane Replied 1 month ago

Victor is the site owner, i am the IT specialist who works for his websites
He didnt inform me about this
He messed up with the server
He does things without letting me know ....
Sorry about that ~Z~ Man

German ~Z~ Man Replied 1 month ago

I think you should check with Victor first. It doesn't help much, to open two channels for the same problem.

Since I see a lot of type 500 errors, it's likely you stopped the webserver's rewrite engine from working as intended some way. Compare your saved 4.6 .htaccess file with the currently installled one.