OSSN Video Component Won't See /usr/bin/ffmpeg

Dusty Bradshaw Posted in Technical Support 2 weeks ago

Hey guys I installed ffmpeg on Ubuntu and and have tried to get the video component to recognize the path. It doesn't and I am a bit stymied.

which ffmpeg returns /usr/bin/ffmpeg but the component settings keep complaining that it can't find the binary.
FFMPEG Status
FFMPEG Binary not found

I have error logging and it returns:

[11-Sep-2020 02:40:00 UTC] PHP WARNING: 2020-09-11 02:40:00 (UTC): "unlink(/var/www/html/ossn_data/tmp/videos/3215cc278d87a6dae46474ff7b5fad10.mp4): No such file or directory" in file /var/www/html/ossn/components/Videos/actions/add.php (line 89)

I am assuming because the upload or conversion fails.

What am I doing wrong here?

Replies
us Dusty Bradshaw Replied 1 week ago

Thanks ~Z~ Man! You are the man! I guess I had a brain lock on this but I swear I tried it every which way. In any case I included the "/ " and it is now working perfectly.

Test Video Working

I am sorry for the silly question but I appreciate your quick response and I absolutely love OSSN. :)

German ~Z~ Man Replied 1 week ago

Most likely you entered /usr/bin/ffmpeg
The component is asking for the directory path instead,
so please try /usr/bin/