TextAreaSupport Issue

Allon Prooit Posted in Performance and Scalability 2 months ago

I am using OSSN 5.6 for the moment and want to upgrade TextAreaSupport. Right now I'm stuck using V 2.11 and I can't disable it or delete it via the Admin page. Any thoughts? Do I have to manually delete it to install a newer version? If so, how? Any help is appreciated!

This topic has been closed!

[Topic is Close]

Replies
Indonesian Arsalan Shah Replied 2 months ago

Hi Allon,

No offense Arsalan, but who are you to say that no one can help me with my OPEN SOURCE SOCIAL NETWORK?

Please don't consider this rude but the simple answer is, I am the owner of the project to tell you that. I speak for myself , my team and my projects. I can't speak for others outside here. The product you are using is not a open source it is OpenTeknik product comes with their own license and owned by them and the supports ends as soon as you modify it. I am closing this thread you won't get support from us here or on openteknik channel because of this reason, unless its about latest version.

However you are welcome to use it and customize it as per your need without our help. Your future posts related to bugs here and openteknik will be closed and unanswered because we don't have time to spend long hours on debugging the issues and then at the end we found its because of customized mixed files. However you are welcome to fix with someone else help but not here. You are welcome to use proper new versions and report issues get it fixed if it is in latest version.

I would like remind you that old versions are vulnerable to the attacks and we didn't published critical vulnerabilities in change logs. You are using it on your own risk.

At the end I would also like to mention that its not like we don't wanted to support you but we also have some rules that people need to follow, for us to help you. I understand that you modified the files and it will lose your changes and yes its hard to work again to make months of customization back. https://www.opensource-socialnetwork.org/wiki/view/704/should-i-modify-core-files but sadly it that's the consequences of modify the files it makes you hard to upgrade.

German Michael Zülsdorff Replied 2 months ago

Allon,
one day ago you wrote: "Y'all seem to think we should all walk lock step into the newest versions of OSSN whenever they arrive..."
And I can only wonder, because it was YOU who started this thread with "I am using OSSN 5.6 for the moment and want to upgrade TextAreaSupport."
Why?
If you have a look into the changes on my "Textarea Support About Page"
https://comz.z-mans.net/group/1/about
you'll notice that using TextareaSupport V 2.11 with Ossn 5.6 is absolutely okay.

us Allon Prooit Replied 2 months ago

No offense Arsalan, but who are you to say that no one can help me with my OPEN SOURCE SOCIAL NETWORK? This is open source! Is it not? You seem to think that the entire community is using 6.x at this time. I eould assume that most of us bought into the possibilty that an open source social network would be nice to take, make use of, and alter according to OPEN SOURCE possibilities. Now your saying all previous open source social network installations are too outdated to be updated, or changed given what we've done. I bought the Premium version of OSSN years ago and made it look good. Now your telling me no one can help me because it's not 6.x. Give me a break. I took the OPEN SOURCE system you sold me and made it gold! Now, if I want your help you expect me to upgrade to a new one that doesn't keep any of my lovely open source changes. Nah, I'll keep using OSSN 5.6 until the cows come home. I'll change it as much as I care to because it's OPEN SOURCE. Quit telling me no one can help me, especially when you're really just referring to you and Micheal. Thanks!

Indonesian Arsalan Shah Replied 2 months ago

No offense here Allon but no one can provide the support anymore to you here nor on paid channel because you are using old OSSN. If something happens only God and you can help to fix that.

If you made some stuff work please don't come here for support because it's you who made it worked on unsupported version and then error born.

us Allon Prooit Replied 2 months ago

Ok. Wow! I'm not a hacker. I resent you calling me that. In fact, it's prolly libel. I'm a coding stitch witch that takes what I've got and makes it work. Y'all seem to think we should all walk lock step into the newest versions of OSSN whenever they arrive. I tried to upgrade to OSSN 6.x twice and it didn't work right both times. I've been working with the Premium OSSN's for over 3 years now. Remixed and produced 5 components for everybody and you have the gall to call me a hacker? Take a walk Micheal. Oh and thanks for the custom Bio component. It work's for OSSN 5.6 just fine.

German Michael Zülsdorff Replied 2 months ago

Allon,
you wrote:

Just had to ftp the newest version to the server to overwrite the older version. First time upgrading a component this way.

Yeah, that's right in line with your answer here:
https://www.opensource-socialnetwork.org/component/view/5923/privacy-changer

You are a hacker, giving a damn on any dependency checks we have implemented for good reasons and on reading component descriptions and how-tos.

You're not running Ossn 5.6, you're running a mix of everything that could be somehow tricked into installing - and you really expect anyone else to be able to figure out what's going wrong because of that?

us Allon Prooit Replied 2 months ago

Ok, well noted. Perhaps someone else in the Community is still working with it and can help. Anyone?

Indonesian Arsalan Shah Replied 2 months ago

We don't support OSSN 5.6 and can't help you with OSSN 5.x

us Allon Prooit Replied 2 months ago

Was able to figure it out on my own. Just had to ftp the newest version to the server to overwrite the older version. First time upgrading a component this way. The TinyMCE editor works fairly well but doesn't post images to the BIO page like it should. Could it be because I'm using PHP 7.4? Regardless, the BIO component hasn't worked right since I upgraded to 5.6 a while back. Anyone else having this issue?