OSSN 5.2 - Apache|Ubuntu - Component Enabling causes HTTP 500

Emil Andrè Hagen Posted in Technical Support 6 months ago

Hi,

Fresh install of OSSN on Ubuntu 20.04 Focal, Apache 2.4.41, PHP 7.4.
Followed the steps to take BEFORE installing on PHP 7.4 (Adjust the 2 code chunks) although this issue happens anyway.

Install completes -> login as admin -> Components -> installer.
Pick textarea-support-2.7.zip (freshly downloaded)
Uploads and installs fine.
Go to enable -> http 500 complete website crash.
Request; (hostname masked)

GET /action/admin/cache/flush?ossn_ts=1591965383&ossn_token=3bc2fe021f4475d7ac3b55afa1459009 HTTP/1.1
Host: xxxx
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache
Upgrade-Insecure-Requests: 1
DNT: 1
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Referer: http://xxxx/administrator/components
Accept-Encoding: gzip, deflate
Accept-Language: en-GB,en;q=0.9,nb-NO;q=0.8,nb;q=0.7,en-US;q=0.6
Cookie: PHPSESSID=pgn78vps0asa6kd01550eitink; ossn_chat_bell=off

Response;

HTTP/1.0 500 Internal Server Error
Date: Fri, 12 Jun 2020 12:36:23 GMT
Server: Apache/2.4.41 (Ubuntu)
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Content-Length: 0
Connection: close
Content-Type: text/html; charset=UTF-8

I can recover the system by deleting the components folder via SSH and the system restores.
I can then try to do it again, but this 500 response comes over and over.

Apache2 logs are clean and gives no indication of problems.
Where do I begin to troubleshoot this?

[PHP Modules]
calendar
Core
ctype
curl
date
dom
exif
FFI
fileinfo
filter
ftp
gd
gettext
hash
iconv
imagick
json
libxml
mbstring
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
sodium
SPL
standard
sysvmsg
sysvsem
sysvshm
tokenizer
xml
xmlreader
xmlwriter
xsl
Zend OPcache
zip
zlib
Am I missing something? I saw some posts about MCrypt, although this is no longer available in 7.4 I also see no indication OSSN does NOT work entirely on 7.4php

Please help. I've cleared cache and cookies, also used other web-browsers.

Replies
German ~Z~ Man Replied 2 weeks ago

In advance: I'm not the guy who would silently apply a crash fix. If I HAVE made a mistake, I would name it. See the release note v 1.22 of GreenByGreen.
Having a look at TextareaSupport there are in fact no crash fixes, just some enhancements. That's why I wouldn't spend a thought on what was different with 2.7
Regarding a 'fresh' install of Ossn 5.5: It's of course never a bad idea to install the latest Ossn update, but even here I don't know any core changes that would have an impact on the component installer.
So, all we can do is having a look into our error logs and trying to find a reasonable message.

us BlkWolf LanHunter Replied 2 weeks ago

My issue was addressed and not related to the component upload itself I'm afraid. The issue I faced was more around being a new user and understanding how the tool operates. During that I had my system in a state where any component added would result in 500. What I found difficult to find was what to do in the event (generically) when a component is added and causes 500 error, what do you do to revert. Again, more my inability to locate on the site, mixed with my own learning mistakes.

I did go to the TextareaSupport Component page and tried to find the 2.7 version to test locally and see if I had any problems w/ that version of the component with php7.4, but see it is not available on the list to download. My assumption that is with good reasons as issues were discovered and addressed.

I come from 35 years technical administrations career, ending the last 11 years as a director over an application service team. I understand the challenges in issue tracking and keeping the details square updated. You all are doing great work and I can only hope to be helpful along the journey.

~Z~ I'm happy to help and test the versions if its available out there. I think that Emil should consider updating the status so we know where they left off or consider a fresh install w/ 5.5 and TextareaSupport 2.11 and see if that solves. I have some site usability observations from a new user perspective I could share but I see that as a different subject.

Cheers

German ~Z~ Man Replied 2 weeks ago

Oops, that's a completely new aspect :(
If I'm not getting you wrong, BlkWolf, TextAreasSupport wasn't involved at all in your case, but a different coomponent? Which component?

us BlkWolf LanHunter Replied 2 weeks ago

Good day ~Z~

Happy to help anyway I am able w/ this question. I would like to clarify some observations about this thread as well some needed updates from original poster.

  1. Reading through the thread it seamed to stall and picked up a few weeks back w/ an additional question added about "htmlpurifier-4.12.0-lite.zip".
  2. Few days ago I added to this thread as I experienced a similar crash while adding a component (not the same component) and was looking for recovery steps. (which I was able to get through. Again, deepest thanks)
  3. The versions and modules reported in original is against TextareaSupport 2.7. The version I have pulled from the site during upgrades brought me to TextareaSupport 2.11.
  4. I see that the TextareaSupport 2.11 reports as nearly a year old which, the post 5 months back would have pulled this version vs 2.7. (Emil would need to provide back confirmation)
  5. Following the original Q/A with Emil in this thread, it looked as if he last reported having package and unzip issues with php7.4. (Given 5months time now, does he still have this issue or was it fixed and never confirmed on the thread?)

So far, I have a strong running OSSN 5.5 version up and running w/ TextareaSupport 2.11 with videos showing up as designed. I think that to proceed with this one, we will need original poster to provide some confirmation of current state of their project and where it was left off, or was it resolved?

  1. Has the latest TextareaSupport 2.11 been tried and does it result in same error?
  2. Assuming fresh install occurred from site, that version 5.4 was 5.5 looks like released in Aug.
  3. Assuming 2. is True, have you performed fresh update using 5.5 and latest packages to see if you get the same error? If so, the question to me would point back to getting php7.4 setup on the server.

Hope its some help. Appreciate the community spirit and hope to give back some of the help I have already received.

Cheers

German ~Z~ Man Replied 3 weeks ago

Thanks for your feedback, BlkWolf.
Honestly, I'm still clueless. I did my best to trigger that issue this morning - to no avail.
1. I decreased the allowed file upload size to 200k (TextAreaSupport is about 500k):
Got a correct error message and the component didn't install at all.
2. I decreased the default PHP execution time (30 sec) to 1 second
The component installed completely - no issue

So how to proceed?
1. - if not already done - enable Ossn Error Reporting from your Admin backend->Basic Settings.
2. -since you know how to disable a component via phpmyadmin - enable TextAreaSupport again this way and check Ossn's local error_log file and your server's main log, most often located in /var/log/apache2
Maybe this will give us some more hints.
3. please unzip the component archive locally and compare with the structure that has been installed in /components/TextareaSupport on your server. Are there any differences?
4. Disable TextaraSupport again via phpmyadmin
remove the TextAreaSupport directory manually
disable mod_security
try installing the component again

us BlkWolf LanHunter Replied 3 weeks ago

The pleasure is mine sir.
I ran into a little trouble getting the system-info/ component to work. (Im sure its an issue on my understanding)

That said, in my .htaccess file confirm the default values are still set for php5 and php7.

<IfModule mod_php5.c>
        php_value memory_limit 128M
        php_value register_globals 0
        php_value post_max_size 8388608
        php_value upload_max_filesize 5242880
        php_value default_charset "UTF-8"
</IfModule>   
<IfModule mod_php7.c>
        php_value memory_limit 128M
        php_value register_globals 0
        php_value post_max_size 8388608 
        php_value upload_max_filesize 5242880
        php_value default_charset "UTF-8"
</IfModule>

As I went through recent install/setup challenges, I too ran into much the same problem with the page going blank and unable to find any error. In my case I believe it to be a database integrity issue as I was still learning much about the app and working around things like the installer.

I'm also using mod_security w/i my apache. so far, no issues in use. Hope it helps sum.

Cheers

German ~Z~ Man Replied 3 weeks ago

Thanks for your help, BlkWolf.

The part I'm more interested in, though, is: How is it possible to end up with a incompletey uploaded component - without getting any errors from the installer?
Could you do us a favor and tell us your upload_max_filesize please?
You can use our SystemInfo component for retrieving information like that.
https://www.opensource-socialnetwork.org/component/view/1963/system-info

BTW: You may disable/enable components with the standalone ossninfo.php, too, which comes included with the System Info component. See TOOLS-README.txt for detailed instructions.

us BlkWolf LanHunter Replied 3 weeks ago

Hello ~Z~ and Emil,
I am new to the app and recently ran into the same problem. I was able to find and address using the following steps.
1. Log into your local phpmyadmin url and open your database table ossn_components. This will show a table w/ all your components and which ones are enables. save this page and continue
2. Log into system and cd /var/www/html
3. php -f index.php
4. for myself, it returned an error indicating the component name that was returning an error along w/ the file. From here you can get the component it tried to load.
5. Return to your phpmyadmin and find the component and set Active from 1 to 0 save the entry by leaving the field.
6. verify by rerunning: php -f index.php
This time I received HTML vs error.

Hope it helps. Thanks for the great content! I look forward to some more classic games. Cheers mate

German ~Z~ Man Replied 1 month ago

Would you please answer my question, Matt?

German ~Z~ Man Replied 1 month ago

Ok Matt,
your website was crashing with a HTTP 500 error.
How could you go into basic site settings and enable error reporting, then?